
Musica e Suono (autore: Vittorio Albertoni)

In una prima parte ci occupiamo del software per indicare al computer che suoni generare e nella seconda ci
occupiamo del software per manipolare questi suoni.
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1 Produzione del suono

1.1 Sequencer MIDI

Il sequencer MIDI è uno strumento, hardware o software, con cui si può creare una serie, una sequenza di
segnali di controllo MIDI e riprodurli in suono.

I moderni computer hanno le caratteristiche per poter scrivere, editare ed eseguire la sequenza come
programma informatico e, con la loro scheda audio, fungere da sequencer hardware.

Nell'allegato PDF �scrittura� all'articolo �Software libero per scrivere�, parlando dei software per scrivere
partiture musicali Frescobaldi e Muse Score, vediamo che essi, come prodotto secondario rispetto al loro
primario scopo di scrivere spartiti, confezionano un �le MIDI, innanzi tutto per darci modo di sentire,
almeno in via approssimata, il risultato sonoro di ciò che abbiamo scritto in notazione musicale: pertanto già
questi programmi possono fungere da sequencer software.

Un sequencer software MIDI deve però avere due cose in più.
Innanzi tutto dovrebbe essere in grado di produrre il �le MIDI traducendo in segnali di controllo l'input

inviato da un musicista che suona su una tastiera collegata al computer. Esistono tastiere MIDI, dette anche
controller, oggi collegabili via USB (non più con il cavo pentapolare di qualche anno fa), che mandano il
segnale MIDI al computer in modo che il computer acquisisca e tramuti in controllo MIDI da inserire nel
�le MIDI la nota suonata, la sua durata e la forza con cui è stato premuto il tasto (velocity): con questo
sistema è chiaro che si tende ad acquisire l'estro interpretativo del musicista, ciò che non sarà mai possibile
attraverso l'indicazione delle note e della loro durata con il mouse in una interfaccia gra�ca.

In secondo luogo dovrebbe dare la possibilità di editare il �le dei controlli in modo da poter intervenire con
modi�che e nuovi inserimenti, al �ne di arricchire il �le stesso con controlli non altrimenti inseribili (pensiamo a
controlli per la disposizione stereofonica del suono, per l'espressione, il portamento, la modulazione, il cambio
dello strumento musicale, ecc.).

Purtroppo non mi risulta esistano software che, senza tanto impegno di risorse e di capacità di organizzarle,
alla possibilità basica di inserire le note e la loro durata con il mouse, si limitino ad aggiungere solo queste
due cose: bisognerebbe risalire alla edizione di alcuni anni fa del PowerTracks Pro della PG Music.

Dovremmo allora ricorrere a programmi che danno la possibilità di aggiungere e registrare anche �le
audio per arrivare a costruzioni complesse da studio di registrazione. Al capostipite di questo software,
Cubase della Steinberg, altri se ne sono aggiunti, come Sonar della Cakewalk, Logic Pro X della Apple, tutti
costosi software commerciali. Nel software libero del mondo Linux, per arrivare ad emulare abbastanza da
vicino Cubase occorre il concorso di almeno tre programmi: Rosegarden (una cui versione, almeno come
sequencer MIDI, gira anche su Windows), Ardour e Hydrogen (entrambi disponibili anche per Windows e OS
X). Esiste pure, in questo campo, una distribuzione Linux che raggruppa questo ed altro: Ubuntu Studio,
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opportunamente dotata di un kernel a bassa latenza (come si preme il tasto di una tastiera collegata si sente
immediatamente il suono).

In ogni caso si tratta di programmi di alta professionalità, di con�gurazione e funzionamento alquanto
complessi, che richiederebbero un manuale di buone dimensioni solo per loro. Chi fosse interessato ad un
approfondimento sull'uso di questi software nel mondo Linux può ricorrere alle ottime indicazioni di Stefano
Droghetti, reperibili in rete indicandone nome e cognome in una barra di ricerca o, per un eccellente riepilogo,
andando sul sito

sites.google.com/site/stefanodroghetti/produzione-musicale.
In questa sede, almeno per ora, ci accontentiamo dei �le MIDI che ci passano i due software che abbiamo

visto per la scrittura musicale, Frescobaldi e Muse Score, descritti nell'allegato all'articolo �Software libero
per scrivere�.

1.2 Arranger MIDI

Molti lettori conoscono certamente quelle tastiere che consentono di scegliere un ritmo musicale, ad esempio
la rumba, di suonare con la mano destra la melodia e con la mano sinistra, semplicemente premendo un
paio di tasti, ottenere un accompagnamento ritmico del tipo scelto, armonizzato con la melodia secondo le
indicazioni sintetiche provenienti dalla mano sinistra. Il risultato che si ottiene non sarà certo il massimo
dell'espressione musicale ma può essere alquanto divertente. Queste tastiere sono degli arranger hardware.

L'arranger MIDI è un software che fa la stessa cosa secondo indicazioni date al computer utilizzando la
sua tastiera (non una tastiera musicale collegata), registrando il tutto in un �le MIDI.

1.2.1 Musical MIDI Accompaniment (MMA)

Lo troviamo su mellowood.ca/mma/ e funziona su Linux, il suo ambiente nativo, su Windows e su OS
X, secondo le istruzioni di installazione presenti sul sito stesso, dove è disponibile ampia documentazione
sull'utilizzo del software, purtroppo solo in inglese.

L'ambizione di MMA è quella di sostituirsi al software commerciale Band-in-a-Box della PG Music e direi
che ci riesce abbastanza bene, anzi...: l'unico problema - che è poi molto relativo perché basta prenderci la
mano - sta nel fatto che, a di�erenza di tutti i moderni software, non ha interfaccia gra�ca.

Pertanto occorre scrivere, utilizzando un editor di testo (per esempio gedit in Linux, blocco note in
Windows, Text Edit in OS X), una serie di istruzioni in linguaggio adatto con le quali costruire poi il �le
MIDI.

La �gura 1 mostra una sintesi dei comandi per la creazione di una base di accompagnamento.
Le istruzioni vanno indicate, nell'ordine, una per riga. In mancanza di istruzioni valgono quelle di default.
L'unica istruzione di apertura necessaria è quella del groove, cioè della routine che esegue l'accompagna-

mento secondo un ritmo determinato.
I groove disponibili si trovano elencati e descritti nella sezione The Standard Library Reference del Manuale

di MMA, che necessariamente occorre scaricare dal sito da cui è stato scaricato il programma e memorizzare
sul proprio computer al �ne di averlo disponibile anche in assenza di collegamento Internet. E' importante
scorrere tutta la libreria per rendersi conto di quali siano le routine disponibili, con le loro varianti (ogni
routine, infatti, è scomposta in parti per l'introduzione, per la �ne del brano, per varianti intermedie, ecc.)
e di quali strumenti si avvalgano.

Il manuale, poi, contiene le istruzioni necessarie per come noi stessi possiamo costruire delle routine da
riutilizzare.

Una volta indicato il groove, occorre esporre l'armonia alla quale esso si deve attenere, scrivendo gli
accordi in modo che ogni riga corrisponda ad una misura del nostro brano musicale (la misura è lo spazio tra
due barrette verticali del pentagramma).

Gli accordi si indicano utilizzando la notazione musicale anglo-sassone con lettera maiuscola immedia-
tamente seguita dal modi�catore necessario per de�nire il tipo di accordo (in mancanza di modi�catore si
ottiene l'accordo maggiore). La �gura 2 mostra i modi�catori che possiamo utilizzare.

Per ottenere un giro di Do in ritmo di beguine, per esempio, scriviamo su un editor di testo quanto segue:
groove beguine
C
Am
F
G
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Figura 1: Sintesi del linguaggio MMA
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Figura 2: Modi�catori per l'indicazione degli accordi in MMA
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Figura 3: Sintassi per l'inserimento di note nella traccia Solo MMA

5



C
e memorizziamo su un �le che denominiamo, per esempio, Beguine.mma in una directory che ci sia comoda

da raggiungere.
Apriamo il terminale di Linux (che in Windows è la �nestra che si apre con il comando cmd e in OS X

con il comando terminale su spotlight), andiamo nella directory dove abbiamo memorizzato il �le e lanciamo
il comando

mma Beguine.mma
Nella stessa directory viene immediatamente generato il �le MIDI Beguine.mid.
Come troviamo indicato nella �gura 1, nel momento in cui scriviamo nell'editor di testo le nostre istruzioni,

possiamo importare una melodia MIDI già esistente oppure scriverne una noi secondo la sintassi riepilogata
nella �gura 3.

Sembra laborioso ma, se ci si abitua, è molto redditizio.
Del resto, anche lavorando con Band-in-a-Box le cose non sono molto meno complicate e non è possibile

inserire la melodia in una traccia Solo con le coloriture che ci consente MMA.

1.2.2 Impro-Visor

Impro-Visor, scaricabile dal sito sourceforge.net/projects/impro-visor/, essendo programmato in linguaggio
Java, funziona ovunque sia installata la virtual machine di Java: il sito propone installatori speci�ci per
Linux, Windows e OS X. Basterebbe comunque scaricare il �le improvisor600.zip, estrarlo in un qualsiasi
posto del computer ed eseguire il �le improvisor.jar con il comando java -jar improvisor.jar.

Inserendo il nome del software in una barra di ricerca si viene indirizzati a documentazione varia e a
qualche tutorial, tra cui, fondamentale e ben fatto, quello dell'ideatore del software Bob Keller all'indirizzo
/www.cs.hmc.edu/~keller/jazz/improvisor/ImproVisorTutorial4.htm.

Fa praticamente le cose che fa il programma MMA che abbiamo visto nel precedente paragrafo con il
vantaggio di farci lavorare con un'interfaccia gra�ca.

Si tratta però, innanzi tutto e soprattutto di un software didattico per jazzisti che, come dice Bob Keller,
è uno strumento di notazione musicale concepito per aiutare musicisti improvvisatori a studiare progressioni
armoniche e costruirci sopra assoli monofonici.

Vediamo innanzi tutto quella che è probabilmente la prestazione più banale del software, quella di creare
una melodia accompagnata, alla stessa stregua di quanto possiamo fare con MMA.

La �gura 4 mostra la schermata di lavoro di Impro-Visor.
La prima cosa da fare è aprire un nuovo Leadsheet1 con il menu File -> New Leadsheet e ci troveremo

di fronte una schermata come quella della �gura.
Poi inseriamo gli accordi che formano l'armonia del brano, scrivendoli nella barra intitolata Textual

Entry. L'accordo è identi�cato dalla sigla della nota del basso con la notazione anglosassone e con un
modi�catore: grosso modo vanno bene le indicazioni che troviamo nella �gura 2. Comunque dal menu Help
-> Impro Visor Help -> Chords accediamo alla tabella completa delle sigle dei vari tipi di accordo.

A questo punto dal menu Preferences -> Open preferences cominciamo ad aprire la scheda Glo-
bal, dalla quale scegliamo, da un menu a tendina, lo stile che dovrà caratterizzare il nostro brano (lo stile
di default è Swing), gli strumenti, sempre con menu a tendina, che dovranno eseguire il basso, gli accordi e
la melodia e regoliamo il volume totale per il brano, quello dell'ingresso e quello delle singole linee di basso,
batteria, accordi e melodia. Apriamo poi la scheda Leadsheet settings, nella quale, oltre a poter indicare
titolo e autore del brano, dovremo scegliere il tempo (di default 4/4), la tonalità, indicando il numero di diesis
o bemolle che dovranno comparire in chiave, il tempo di metronomo e le misure che formeranno il brano, che
faremo coincidere con quelle occupate dalle nostre indicazioni degli accordi.

Arriviamo così al momento di inserire la melodia e, per fare questo, abbiamo tre strade: il mouse andando
a cliccare sul rigo la posizione delle note che vogliamo inserire, la barra intitolata Textual Entry in cui
scrivere le note secondo le notazioni previste dalla tabella che troviamo in menu Help -> Impro Visor

Help -> Melody o una tastiera MIDI collegata al computer (da attivare andando a sceglierla in menu
Preferences -> MIDI -> Select a device for MIDI input: se non troviamo elencata la tastiera nel
menu a tendina vuol dire che c'è qualche cosa che non va nel suo collegamento o nella sua capacità ad essere
utilizzata).

1Un leadsheet è un rigo musicale con indicata la melodia di un brano, al quale si sovrappone l'indicazione delle sigle degli
accordi che costituiscono l'armonia del brano stesso. E' altrimenti chiamato fakesheet ed è molto utilizzato dai jazzisti che se
ne servono per crearci sopra le loro improvvisazioni. Esistono raccolte di brani e canzoni in questa forma, nel caso delle canzoni
con scritte, sotto il rigo musicale, le parole della canzone sillabate sotto le note: raccolte che si chiamano fake books.
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Figura 4: Schermata di lavoro di Impro-Visor

Possiamo anche importare la melodia da un �le MIDI altrimenti generato utilizzando il menu File ->
Import MIDI Tracks from File.

Il nostro lavoro possiamo salvarlo, man mano che procede, con il menu File -> Save Leadsheet As e,
una volta terminato, possiamo generare il �le MIDI con File -> Export Leadsheet to MIDI.

Fin qui può arrivare tranquillamente il dilettante che abbia un minimo di infarinatura e propensione
musicale.

Il musicista professionista potrà trovare molto altro in questo prezioso software, sul quale peraltro si
continua a lavorare per aggiungere miglioramenti e nuove funzionalità.

Per avere un'idea basta inserire un accordo e la relativa tonica sul rigo (ad esempio C come accordo e c

come nota) e studiare ciò che ci si presenta premendo la piccola icona nella barra degli strumenti.

1.3 Dal MIDI al suono

Una volta che abbiamo il nostro �le MIDI possiamo derivarne suono con i normali riproduttori audio che
abbiamo sul computer: se non sono dotati del plugin necessario se lo vanno a cercare e ci chiedono il permesso
di caricarlo. Ma, in questo caso, la produzione del suono avverrà con lo strumento base del sistema su cui
lavoriamo, che, in genere, è la tavola sonora. E i risultati saranno alquanto mediocri.

Solo utilizzando il �le MIDI con gli strumenti che vedremo adesso abbiamo modo di scegliere i sound fonts
con cui e�ettuare la produzione del suono e, se ci piace questa produzione, possiamo �ssarla in un �le audio,
in modo da poterla poi sentire dove vogliamo: attraverso un CD in macchina, su un lettore MP3 per strada,
ecc.

Se il nostro �le MIDI è fatto bene, conserviamolo comunque. E' leggerissimo da trasferire, anche per posta
elettronica, e può sempre essere utilizzato da strumenti in grado di cavarne suoni migliori di quelli possibili
con il nostro computer: o da altri computer con sound fonts migliori dei nostri o da sequencer hardware o
expander esterni al computer. Il MIDI è uno standard valido per tutti questi strumenti.

1.3.1 TiMidity++

Timidity++ è un software a riga di comando con il quale, utilizzando sound fonts da noi scelti, possiamo
ascoltare i suoni prodotti leggendo un �le MIDI e li possiamo registrare in un �le audio.
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Il sito di Timidity++ è timidity.sourceforge.net/ e vi troviamo tutte le informazioni sul software con i
link per scaricare le varie versioni, disponibili per Linux, Windows e OS X. Chi lavora su Linux dovrebbe
trovarsi Timidity già installato come daemon nel sistema operativo. Chi lavora su Windows ne trova una
versione dotata di discreta interfaccia gra�ca su sourceforge.net/projects/twsynth/. Chi lavora su Mac si può
rivolgere a spam-�lter.de/osx/timidity, dove pure si trova una versione, detta �cocoa�, con interfaccia gra�ca;
penso tuttavia che su OS X sia installabile e utilizzabile la stessa tarball per la versione a riga di comando
predisposta per Linux (tra Unix like ci si intende).

La prima cosa da fare perché Timidity funzioni è sistemare il suo �le di con�gurazione, che si chiama
timidity.cfg.

In Linux, se Timidity esiste come daemon, si trova in /etc/timidity.
Altrimenti occorrerà crearlo con un editor di testo e sistemarlo, per esempio, in Linux e OS X, in una

directory /usr/local/share/timidity e, in Windows, nella stessa directory in cui sta il programma (ad esempio
C:\timidity++).

Il �le di con�gurazione indica a Timidity quali sound fonts utilizzare e, pertanto, conterrà istruzioni come
queste:

• dir seguito dal percorso per raggiungere la directory dove sono archiviati i sound fonts,

• source seguito dal �le di con�gurazione del sound font, quando questi siano organizzati in archivio,

• soundfonts seguito dal nome del �le con estensione .sf2 se il sound font è compattato in un solo �le.

L'uso di Timidity++ per chi ha l'interfaccia gra�ca è intuitivo.
Se si utilizza la riga di comando basta tenere a mente un paio di semplici comandi da scrivere con la

tastiera nel terminale Linux (che in Windows è la �nestra che si apre con il comando cmd e in OS X con
il comando terminale su spotlight). Gli utenti Windows dovrebbero preventivamente includere la directory
dove è ospitato il programma nel Path, altrimenti le operazioni diventerebbero alquanto macchinose.

Una volta posizionati nella directory dove è memorizzato il �le MIDI, per ascoltare il suono prodotto dal
�le stesso o per registrare questo suono in un �le audio di formato .wav i comandi sono, rispettivamente:

timidity seguito dal nome del �le MIDI (nome comprensivo dell'estensione .mid)
timidity -Ow -s44100 seguito dal nome del �le MIDI e dal nome che si vuol dare al �le audio (con estensione

.wav).
I difetti di questo sistema sono due: innanzitutto quello di aver scelto i sound fonts in blocco, quando ci

potrebbe interessare attingere il suono della tromba da un archivio di sount fonts e il suono della chitarra
da un altro; inoltre quello di utilizzare un �le MIDI non sottoponibile ad editing dopo la sua produzione,
in quanto abbiamo detto di non aver trovato, nell'orto del software libero, un sequencer semplice che faccia
l'editing degli �eventi� MIDI, come si chiamano le istruzioni in linguaggio MIDI.

Quest'ultimo difetto potrebbe essere secondario nel caso di �le MIDI prodotti da noi e dall'origine im-
prontati al nostro gusto ma, se volessimo intervenire su �le MIDI prodotti da altri, sarebbe tutto molto
complicato.

1.3.2 SynthFont

I due difetti segnalati per Timidity sono ampiamente superati da questo software che mi sento autorizzato a
citare in una rassegna dedicata al software libero pur non essendo un software libero. Esso è infatti soggetto
all'acquisto di una licenza contro versamento di un obolo, attualmente di una quindicina di euro, al suo
autore e manutentore Kenneth Rundt. E' scaricabile dal sito synthfont.com/, dove è consultabile un ottimo
tutorial.

Mi prendo l'autorizzazione in quanto, nel pur scon�nato mondo del software libero, non c'è nulla che ci
consenta di fare in maniera così semplice le cose intelligenti che ci consente di fare SynthFont.

Purtroppo SynthFont è stato programmato per Windows e non è disponibile per Linux e per OS X.
Su Linux e su Mac OS X occorre utilizzarlo attraverso WINE2.
La �gura 5 mostra la schermata di lavoro di SynthFont.
Vi è caricato un �le MIDI che contiene un arrangiamento della canzone Again di Lionel Newman.

2Wine è un software libero, nato originariamente per sistemi operativi GNU/Linux, poi esteso ad altri sistemi operativi, tra
cui OS X, con lo scopo di permettere il funzionamento dei programmi sviluppati per il sistema operativo Microsoft Windows.
Si trova sul sito winehq.org/.
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Figura 5: Schermata di lavoro di SynthFont

Delle quattro cartelle che contengono le schermate di lavoro, le cui linguette di apertura sono visibili
appena sotto la barra dei menu (Files/Cartelle, Piano Roll, Eventi MIDI e Plug & Play) ora è aperta la Plug
& Play, che è un po' quella che riepiloga tutto.

Nella metà inferiore della �nestra vediamo le tracce MIDI su cui abbiamo le varie parti: dopo una
traccia contenente metaeventi (armatura di chiave, tempo di metronomo) abbiamo la traccia della melodia,
inizialmente a�data alla chitarra jazz (il pulsante con il triangolino sta ad indicare che si alterneranno altri
strumenti, visibili se apriamo il menu a tendina cliccando sul pulsante), il basso, e così via. Cliccando
destro in un punto qualsiasi di una traccia si apre un menu nel quale ci viene proposta una lista di cose che
possiamo fare, tra le quali mi preme sottolineare quella che dice Assegna File SoundFont. Scegliendo
questa opzione ci troviamo di fronte una �nestra di dialogo dalla quale possiamo andare a cercare, dove
l'abbiamo archiviato, il �le di sound font che intendiamo utilizzare per quella traccia (anzi per il pezzetto di
quella traccia che si riferisce ad un certo strumento). In questo esempio vediamo che le raccolte di sound font
interessate sono ben sei: la chitarra jazz è presa dalla raccolta SYNTHGMS, il basso acustico è preso dalla
raccolta FluidR3, il sax tenore ha addirittura un sound font speci�co, ecc.

Superiamo così il primo dei difetti che avevo imputato all'utilizzo di Timidity.
Se selezioniamo la traccia della melodia e andiamo a scegliere la linguetta Piano Roll ci si apre la

schermata riprodotta nella �gura 6.
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Figura 6: Schermata Piano Roll di SynthFont

Qui vediamo la nostra melodia, indicata con lineette più o meno lunghe, a seconda della durata delle
note, in corrispondenza ai tasti di un pianoforte. Se partissimo da zero, in questa �nestra potremmo inserire
le note, come metodo alternativo a quello di inserirle con il mouse su un pentagramma. Nella �nestrella più
sotto una matita mossa dal mouse sta tracciando un diagramma per dare espressione al passaggio iniziale
della melodia. Se clicchiamo sul tasto con il triangolino che vediamo nella �nestrella con scritto Expression
sulla sinistra del diagramma si apre un menu a tendina che ci o�re molte altre possibilità di intervenire
gra�camente con la matita mossa dal mouse: dal volume, al legato, alla posizione stereofonica del suono, ecc.

Se poi andiamo a scegliere la linguetta Eventi MIDI si apre la schermata riprodotta nella �gura 7, che
è un editor degli eventi inseriti nella traccia preventivamente selezionata del nostro �le MIDI.

Figura 7: Schermata Eventi MIDI di SynthFont

Vediamo che, attraverso una gra�ca molto intuitiva, abbiamo la possibilità di scegliere quale tipo di eventi
visualizzare e come intervenire per eliminarli o modi�carli.
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E con questo abbiamo ampiamente superato anche il secondo degli inconvenienti che ci si presentano
utilizzando Timidity.

Una volta sistemato a dovere il nostro �le MIDI, torniamo alla linguetta Plug & Play, clicchiamo, nella
barra degli strumenti in alto, sul pulsante Ascolta e, se il brano è venuto bene e ci soddisfa, memorizziamo
il �le MIDI agendo sul pulsante Salva MIDI (magari anche il �le di lavoro SynthFont con il pulsante Salva
Arrangiamento, per eventuali interventi successivi).

Agendo sul pulsante Riproduci su File registriamo su un �le audio in formato .wav il nostro lavoro.
Un regalo che ci viene fatto acquistando SynthFont è un altro utile software, Viena, con il quale possiamo

noi stessi creare sound fonts.

2 Manipolazione dei �le audio

Una volta creato il nostro �le audio, potremmo aver bisogno di intervenire su di esso o per aggiungere e�etti
speciali, o per estrarne una parte o per trasformarlo da un formato ad un altro.

Quest'ultima funzione è probabilmente la più importante.
I �le audio che produciamo con Timidity con l'opzione -s44100 e con SynthFont sono in formato .wav

(WAVeform audio �le format): sono equivalenti ai �le in formato .ai� del mondo Mac, formato che facilmente
si converte in .wav e viceversa.

Si tratta di �le che immagazzinano i dati derivanti da un campionamento della forma d'onda sinusoidale
del suono, misurandone i valori 44.100 (quarantaquattromilaecento) volte al secondo. Se consideriamo che si
tratta di dati a 16 bit su due canali stereofonici i byte da immagazzinare ogni secondo sono 44.100 x 2 x 2
= 176.400. Per una canzonetta che dura tre minuti la memoria che occupa il �le in formato .wav o .ai�, che
dir si voglia, siccome in tre minuti ci sono 180 secondi, è 176.400 x 180 = 31.752.000 byte, cioè circa 32 MB.

Si dice che, con questa frequenza di campionamento, il suono sia perfetto: non a caso è la frequenza di
campionamento utilizzata per produrre i CD musicali. Ma il �le è molto pesante, sia per la memorizzazione,
sia per il trasporto in rete e si sono trovati tanti modi per ridurlo. A �ni pratici sono due: la riduzione al
formato .�ac (Free Lossless Audio Codec) e la riduzione al formato .mp3 (Moving Picture Expert Group-1/2
Audio Layer 3) che si equivale alla riduzione al formato .aac (Advanced Audio Coding) del mondo Mac.

La riduzione al formato .�ac lascia inalterata la qualità dell'audio (è una riduzione lossless, senza perdita)
e il nostro �le diventa grosso modo la metà di quello che era in formato .wav, ed è già un bel risparmio di
spazio.

Per andare oltre, nel risparmio di spazio, dobbiamo essere disposti a perdere in qualità, cioè occorre
togliere dal �le .wav tutto ciò che può essere considerato un lusso, togliere suoni che si colgono solo con
orecchio ra�natissimo, ecc. Esiste un algoritmo che va a pizzicare tutti questi eccessi e li elimina, arrivando
�no a ridurre il �le a un decimo di quello da cui si è partiti. In questo modo la nostra canzonetta che
occupava 32 MB arriverà ad occuparne 3 (nel formato .aac qualche cosa in più, in quanto il suo algoritmo
è meno spinto). E occorre riconoscere che, se il �le viene riprodotto in un auricolare, su un'autoradio con
l'auto in corsa o su un impianto hi-� domestico di poca spesa, non è che si noti la di�erenza. Certo è che su
un hi-� serio è meglio andarci con un �le .wav o .�ac.

2.1 Audacity

E' il massimo che troviamo nel software libero per il trattamento e la manipolazione dei �le audio.
Su audacity.sourceforge.net/?lang=it troviamo le versioni per Linux, Windows e OS X, con ampia docu-

mentazione, parzialmente in italiano.
Su Linux, soprattutto se carichiamo il sistema operativo Ubuntu o suoi derivati, tipo Mint, dovrem-

mo trovare Audacity già in grado di trattare anche i �le .mp3. In ogni caso, per Linux possiamo tro-
vare il source di Lame (che è un software libero usato per codi�care �le audio in formato MP3) su la-
me.sourceforge.net/index.php. Per Windows e OS X dovremo procurarci Lame, rispettivamente, su la-
me.buanzo.org/#lamewindl e su lame.buanzo.org/#lameosxdl.

Tutte le istruzioni per l'installazione e la messa a punto all'indirizzo
http://manual.audacityteam.org/man/FAQ:Installation_and_Plug-Ins/it#.
La �gura 8 mostra la schermata di Audacity.
Vediamo nei due canali stereo le forme d'onda di un brano caricato in Audacity, pronto per la manipola-

zione.
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Figura 8: Schermata di lavoro di Audacity

Audacity può caricare qualsiasi tipo di �le audio con File -> Apri e lo può convertire in qualsiasi altro
tipo, producendo un �le nel formato del tipo convertito con File -> Esporta.

Aprendo la voce di menu E�etti troviamo la lunga lista di tutto ciò che possiamo fare con Audacity sul
�le che abbiamo caricato (ampli�cazioni, dissolvenze, esaltazione dei bassi, equalizzazione, ecc.): il tutto a
livello molto intuitivo.

L'unico difettuccio di Audacity è quello di lavorare su un �le per volta, il che, nella conversione, per
esempio, di una serie di �le .wav in .mp3 è leggermente scomodo.

2.2 SoundConverter

Per il mondo Linux abbiamo SoundConverter, in genere incluso nelle distro, che fa solo conversioni di �le
audio, ma le fa proprio tutte, da qualsiasi tipo di �le a qualsiasi altro tipo, e le fa anche per lunghe liste di
�le e per cartelle di �le.

Su Internet si trovano software omonimi per Windows e OS X che fanno le stesse cose.
Questi software hanno anche la caratteristica di isolare l'audio da clip audio-video: se carichiamo su

SoundConverter un �le .�v di una canzone scaricato da YouTube e lanciamo la conversione, ci ritroviamo il
�le convertito in formato audio contenente solo l'audio del videoclip.
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